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When you try to print an invoice in the Invoice Print
(BI.INV.00)
screen in final mode, the status bar in the Invoice Print
(BI.INV.00)
screen contains the following message:

Printing Completed

However, the pointer turns
into an hourglass, and the invoice does not print.

 

Cause

This problem occurs because records that contain 0.00 in the amount field and the NP value in the in_id18 field are in the PJINVDET table.

 

Resolution

Note Before you follow the instructions in this article, make sure that you have a complete backup copy of the database that you can restore if a problem occurs.

 

To resolve this problem, delete the records that contain 0.00 in the amount field and the NP value in the in_id18 field from the PJINVDET table. To do this, follow these steps:

 

  1. Access the appropriate application database by using SQL Query Analyzer.
  2. Verify that the records that contain 0.00 in the amount field and the NP value in the in_id18 field exist for the draft. To do this, run the following statement.
  3. select * from pjinvdet where draft_num = '<xxxxxxxxxx>' and amount='0.00' and  in_id18 = 'NP'

Note Replace the <xxxxxxxxxx> placeholder with the draft number for which you are printing the invoice.

  1. Delete the records that were returned from the statement that you ran in step 2. To do this, run the following statement.
  2. delete from pjinvdet where draft_num = 'xxxxxxxxxx' and amount='0.00' and in_id18 = 'NP'

Note Replace the xxxxxxxxxx placeholder with the draft number for which you are printing the invoice.

  1. Print the invoice. To do this, follow these steps:
    1. On the Modules menu, click Flexible Billings.
    2. In the Flexible Billings pane, click Invoice Print under Processes.

Specify the appropriate values in the Subaccount box, the Biller box, the Draft Range box, and the Invoice Date box, and then click Print Company Invoices.