System Message 10232 in Dynamics SL
Symptom
The users intermittently receive the following message either during log on or while working in Dynamics SL
System Message 10232
Assertion failure!
File:sqlodbc.cpp
Line: 10675
Expression: hdbcConn !=SQL_NULL_HDBC
Cause
This error can occur when there are clock synchronization issues between the domain controller and the database server
Resolution
More information about Active Directory Time Synchronization is available at the below links. If you need additional assistance, please contact Microsoft Active Directory support.
https://social.technet.microsoft.com/wiki/contents/articles/50924.active-directory-time-synchronization.aspx
https://docs.microsoft.com/en-us/windows-server/networking/windows-time-service/how-the-windows-time-service-works