Views:

SUMMARY
You notice that the default printer is incorrect in Microsoft Dynamics SL. This problem occurs when the following conditions are true:
Microsoft Dynamics SL is installed on a server that is running Citrix Xenapp or Citrix Presentation Server
Microsoft Dynamics SL is configured as a published application

Cause
The problem occurs because the Start this application without waiting for printers to be created option is enabled on Citrix Xenapp or on Citrix Presentation Server.

RESOLUTION
Disable the Start this application without waiting for printers to be created option. For more information about how to disable this option, see the Citrix Xenapp or Citrix product documentation.